Close
Login to Your Account
ModdedRaptor.com - Yamaha Raptor Forum
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Rev Limiter kicks in, no power problem

  1. #1
    Stock, ready to MOD Baja Duner SS's Avatar
    Member #
    4591
    Join Date
    Dec 2010
    Posts
    6

    Rev Limiter kicks in, no power problem

    Over the weekend my 04 Raptor developed a problem with the Rev Limiter. Whenever I put a load on the engine it kicks in the Rev Limiter...for example when I try to wheelie or climb a hill, it kicks in and I have no power.

    It runs fine, starts fine, revs fine. Its bone stock including the pipe.

    Any suggestions on what to try?

    Thanks!

  2. #2
    Stock, ready to MOD Tommy Warren's Avatar
    Member #
    2667
    Join Date
    Oct 2009
    Location
    ontario canada
    Posts
    11
    have you removed the parking break sensor?

  3. #3
    Stock, ready to MOD Baja Duner SS's Avatar
    Member #
    4591
    Join Date
    Dec 2010
    Posts
    6
    I haven't removed it but I unplugged it from the handle bar and clicked on it while it was running and the rev limiter came on.

    So I assumed it was working properly. I'll try unplugging it tonight after work.

    Where does it plug in at?

  4. #4
    Stock, ready to MOD Tommy Warren's Avatar
    Member #
    2667
    Join Date
    Oct 2009
    Location
    ontario canada
    Posts
    11
    I believe its a green wire with a black stripe and a black wire follow them to the connection beside the rad and unplug it there. do not ground any of the wires.

  5. #5
    Stock, ready to MOD Baja Duner SS's Avatar
    Member #
    4591
    Join Date
    Dec 2010
    Posts
    6
    Thanks, will try tonight.

  6. #6
    Stock, ready to MOD Baja Duner SS's Avatar
    Member #
    4591
    Join Date
    Dec 2010
    Posts
    6
    Pulled the parking brake switch off it last night, no luck.

  7. #7
    Bolt-on Beginner urbassicraptor's Avatar
    Member #
    5200
    Join Date
    Apr 2011
    Location
    ft collins colorado
    Posts
    75
    Quote Originally Posted by Baja Duner SS View Post
    Pulled the parking brake switch off it last night, no luck.
    did you ground out the reverse sensor wire? its the wire that slips on the stud next to your front sprocket. not the wire with the eye terminal. just take it and cut the wire end off a couple inches back so you can keep the original plug if you want and put an eye terminal on it. then use the same screw that the ground wire uses on the case and mount it there. After that, when you turn on the key the reverse light will light up for a second then shut back off. you will not have a reverse light anymore but you also will not have a limiter. If the bike still does it then its something else.
    04 660
    102mm bore
    +4 mm stroker hotrods crank
    13.5:1 piston
    Vitos jet kit
    racing clutch
    Monster dual inframe exhaust
    fatbars
    twist throttle
    gusseted frame
    Lenz ported head plus 1 valves
    +2 +1 fullflight a arms
    rhino battery
    No airbox, k&n filter
    1/2 inch carb spacer
    stage 3 cam and hd springs
    led tail lights
    tusk nurf bars
    maxxis razor 2 front and rears


  8. #8
    Stock, ready to MOD Baja Duner SS's Avatar
    Member #
    4591
    Join Date
    Dec 2010
    Posts
    6
    Sweet. Thanks for the advise. Will try tonight after work.

  9. #9
    Modding the Motor 4stroker's Avatar
    Member #
    2190
    Join Date
    Jul 2009
    Location
    michigan
    Posts
    755
    Quote Originally Posted by urbassicraptor View Post
    did you ground out the reverse sensor wire? its the wire that slips on the stud next to your front sprocket. not the wire with the eye terminal. just take it and cut the wire end off a couple inches back so you can keep the original plug if you want and put an eye terminal on it. then use the same screw that the ground wire uses on the case and mount it there. After that, when you turn on the key the reverse light will light up for a second then shut back off. you will not have a reverse light anymore but you also will not have a limiter. If the bike still does it then its something else.
    x2
    BARKERS PEFORMANCE
    TYSON RACING
    US27 MOTORSPORTS
    SANDTOYZ UNLIMITED

    "YES ITS FAST"NO U CANT RIDE IT"

  10. #10
    Stock, ready to MOD Baja Duner SS's Avatar
    Member #
    4591
    Join Date
    Dec 2010
    Posts
    6
    Quote Originally Posted by urbassicraptor View Post
    did you ground out the reverse sensor wire? its the wire that slips on the stud next to your front sprocket. not the wire with the eye terminal. just take it and cut the wire end off a couple inches back so you can keep the original plug if you want and put an eye terminal on it. then use the same screw that the ground wire uses on the case and mount it there. After that, when you turn on the key the reverse light will light up for a second then shut back off. you will not have a reverse light anymore but you also will not have a limiter. If the bike still does it then its something else.
    Did that. Still have the problem. Thanks!

    Going to take the carbs off this weekend and clean them to see if that helps.

Page 1 of 2 12 LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

raptor 660 parking brake rev limiter
,

raptor 660 rev limiter

,

raptor 660 rev limiter bypass

,

raptor 660 rev limiter problems

,

raptor 660 speed sensor

,

raptor rev limiter bypass

,
yamaha raptor rev limiter bypass
,
yamaha rhino rev limiter bypass
Click on a term to search our sites for related topics.