Tick i cant seem to locate
Close
Login to Your Account
ModdedRaptor.com - Yamaha Raptor Forum
Results 1 to 2 of 2

Thread: Tick i cant seem to locate

  1. #1
    Stock, ready to MOD Mopar440ci's Avatar
    Member #
    17570
    Join Date
    Sep 2019
    Posts
    3

    Tick i cant seem to locate

    ok so i have this 03 raptor that i bought tore down to the piston and i put it back together.
    it runs great but had this tick in the top end so i went through it .
    new wrist pin , new rings , polished bore , cleaned head , lapped valves ,new valve seals, new timing chain and tensioner , new gaskets , new exaust gaskets .

    it has WAY more power now ( still not enough , Build over the winter maybe ) but it still had the same tick that is worse with higher rpms. its in the very top end.
    i guess im wondering what it could be so i know what to check next. im really only down to weak valve springs , bad valves or bad cam at this point that i can think of.
    Last edited by Mopar440ci; 09-07-2019 at 12:35 PM.

  2. #2
    Stock, ready to MOD Mopar440ci's Avatar
    Member #
    17570
    Join Date
    Sep 2019
    Posts
    3
    just relized i put this in mods....... was looking at both pages. alredy reposted to mantnance , if anyone can delete this , thanks. i cant figure out how for some reason.
    Last edited by Mopar440ci; 09-07-2019 at 12:45 PM.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •