07 Raptor 700 no start, no fuel pump, no CEL
Close
Login to Your Account
ModdedRaptor.com - Yamaha Raptor Forum
Results 1 to 2 of 2

Thread: 07 Raptor 700 no start, no fuel pump, no CEL

  1. #1
    Stock, ready to MOD brusk's Avatar
    Member #
    16658
    Join Date
    Apr 2018
    Posts
    2

    07 Raptor 700 no start, no fuel pump, no CEL

    Tore apart an 07 Raptor 700 that hasn't been started in a few years. Quad was tore down and rebuilt, went through the wiring and cleaned and greased all the connectors and when it was time to start it wouldn't. Current situation key on, engine switch on I get a neutral light but no other lights and no fuel pump turning on. It will crank but does not get any spark or fuel. Relays for clutch, neutral, fan and light relays work. The fuel pump relay works if I ground the wire at the ECU. I've taken the lean angle sensor apart and made sure it's clean and moving, replaced the fuel pump relay assembly. Thought it must be a bad ECU as it's getting power and ground but not sending any CEL, replacement ECU did not change the symptoms. I've tested several wires at the ECU to test power grounds to different components and can easily kick on the fan, reverse light, check engine light (thought maybe the bulb was bad), fuel pump. At this point I'm at a loss what the issue could be to not at least get a CEL.

  2. #2
    Stock, ready to MOD brusk's Avatar
    Member #
    16658
    Join Date
    Apr 2018
    Posts
    2
    Slightly annoyed and would consider this a defect in the ECU. The connectors for the MAP and TPS were switched. The wiring for each is basically the same as power, output, and signal input. Why that would cause an ECU to become completely unresponsive I don't understand. No I get proper CEL's when doing anything with the sensors and the fuel pump etc is working.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

raptor 700 not getting fuel

Click on a term to search our sites for related topics.