Modded Raptors Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I purchased a 2005 raptor 660 about 2 weeks ago from a guy in Lewiston Idaho. I live in a small coastal town in Alaska so when we got it up here we noticed that there were most likely the wrong jets in it. It ran, but wouldn't idle and throttle response was a little off. After adjusting the idle and jets I blew out the starter clutch because of multiple starts. I think it was going out anyways. After pulling it apart I noticed that all 6 hex bolts had sheared off from the magneto. I ordered an L&A kit and have replaced the clutch. I also purchased a complete carb rebuild kit and have rebuilt both carbs and have rejetted them to stock. After getting everything back together the bike fired right up and seemed to be running great other than a little hesitation that I assumed was the new pilot jets needing adjusting. After letting the bike idle for about 10 minutes I jumped on and gave it throttle and it died. Now it will not start to save my life. I have taken the carbs off again and went through every part I replaced with the rebuild kit. I have made sure the intake boots are seated and I have also checked for spark by pulling the plug. Although the plug is blackened it seems to be getting great spark. I have confirmed that the carbs are getting fuel and the plug also smells of fuel when I pull it so I am sure the engine is getting fuel as well. All the bike will do is turn over and turn over and turn over, but it will not fire. It will not even attempt to fire. Battery is fully charged as well. Any ideas? I am frustrated at this point because everything seemed to be good and then all of sudden its not starting to save my life. Any input is appreciated. Thanks
 

·
Registered
Joined
·
1 Posts
Mine did the same exact thing when I sheared my flywheel key. Long story short, ended up being my stator. Half of it had shut down, thus causing it to give it a spark, but not strong enough to let the beast roar. Not saying that is whats wrong with yours, but I would get that stator checked.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
I also just checked for compression and seem to be getting good pressure. Any other ideas? What is a good way to check the stator?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
will the reverse or parking brake limiter act as a kill switch and cause the bike to not fire? I am running out of options here. The bike acts as if a kill switch is engaged even though it turns over and provides spark but just won't start. Please help!!!
 

·
Registered
Joined
·
554 Posts
ground the revers wire, it will get rid of the reverse limiter.... its the green one down by the shifter. and do the PB limiter mod, research it...
 
1 - 6 of 6 Posts
Top