Modded Raptors Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Okay, so get a beer and some popcorn, this one is long..

2013 Raptor 700R, bought it about a year ago, it had a power commander 3 with no other mods (That i could see).
I installed a baker full dual system and it seems to run great. until my PC3 died (Turns out later it was just a faulty wire)
So i pulled the PC3 out, and removed the Bakers in fear of going lean.

Recently upon checking my oil i noticed it was over full, and smelt of gas. So after looking around on the internet determined it was prob from when i have the baker on, and the tune was not right, so i was flooding my motor???

So, I did an oil change, I rode the quad a few times, no big rips, just around the block sorta thing.Till yesterday i went for a big rip, and i noticed when it got to op temps it power buck and would back fire on decel.

So i thought, maybe the PC3 was suppose to be on there for some reason i can't see EI. cams?? so today i tried re installing the PC3 and lo and behold it not only powered up, but the bike now starts SIGH!.. Haven't drove it yet.

So my question is.. LOL!... If i manage to get the tune off the PC3, can someone tell if the motor has any mods, like a set of cams?? And my second question is, because i did not buy the PC3, will i get support from dynoJet for tunes?

Thanks in advance for any advice or insights.
 

·
Registered
Joined
·
350 Posts
Okay, so get a beer and some popcorn, this one is long..

2013 Raptor 700R, bought it about a year ago, it had a power commander 3 with no other mods (That i could see).
I installed a baker full dual system and it seems to run great. until my PC3 died (Turns out later it was just a faulty wire)
So i pulled the PC3 out, and removed the Bakers in fear of going lean.

Recently upon checking my oil i noticed it was over full, and smelt of gas. So after looking around on the internet determined it was prob from when i have the baker on, and the tune was not right, so i was flooding my motor???

So, I did an oil change, I rode the quad a few times, no big rips, just around the block sorta thing.Till yesterday i went for a big rip, and i noticed when it got to op temps it power buck and would back fire on decel.

So i thought, maybe the PC3 was suppose to be on there for some reason i can't see EI. cams?? so today i tried re installing the PC3 and lo and behold it not only powered up, but the bike now starts SIGH!.. Haven't drove it yet.

So my question is.. LOL!... If i manage to get the tune off the PC3, can someone tell if the motor has any mods, like a set of cams?? And my second question is, because i did not buy the PC3, will i get support from dynoJet for tunes?

Thanks in advance for any advice or insights.
PC3 crap quality. Get PC5 and tune it on the dyno!
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Raptor has a brand new tune thanks to #barkersExhuast sending me one, the dual exhaust is back on and WOW!!!! it's picked up some HPs..
Now i need to fix my front end LOL!..
 

·
Registered
Joined
·
392 Posts
PC3 crap quality. Get PC5 and tune it on the dyno!
There are many mid 80 to low 90 HP duners, hill shooters and flat draggers that were tuned and won many races on PCIII's and there are tons of maps out for them as well. Don't be so quick to condemn the old school PCIII's, they were very reliable and the only option when we started pioneering all the mods and different builds when the 700R's first came out in 07....
 
1 - 7 of 7 Posts
Top