Modded Raptors Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
When I got the PC III it looked pretty beat up so I sent it to Dynatec to have the wiring repaired because there were several wires with cuts in them and two more wires that weren't even mentioned in the description were butt connected together and taped over. They actually said they would fix it for free I also wanted them to do a function check on the unit. THis is what they sent me today:

I received your unit back and your unit already had the TPS connector update done to it. You sent in the two 3pin connectors that are for the TPS but they were cut off the harness. The Injector plug that you sent in is from your stock harness on the quad. The injector plug that is missing on the Powercommander harness you sent in must still be on the stock injector. The unit is itself will not even power up so even if I fixed the harness the unit will still not work. Unfortunately due to the harness damage I cannot cover this under warranty and will be sending it back to you.



Let me know if you have any other questions. Thanks.



Mike Shefler

Dynojet Research Inc.

1-800-992-4993[/QUOTE]

i have no idea what you are even talking about... everything is there that needs to be there... i unplugged it and sent it to you...i have no extra plugs or whatever you are trying to imply... the only plug that is cut off is the one i sent to you and told you about... it worked great on my raptor when it came off so i know there is absolutely nothing wrong with it... just needs to either be spliced in like i said because the plug is cut off or fix the plug...[/QUOTE]

Sorry man I opened a dispute...I thought we could handle this ourselves. This item was not as described...I would be happy to send it back to you for a full refund plus shipping.[/QUOTE]
???are you serious??? i know for a fact it works fine...i had it on my bike and then decided to go back to stock and sold pc3,barkers,and airbox...[/QUOTE]

All I know is the wiring was hacked up way worse than described...thats one reason for a refund...two the manufacturer was not able to get it to even power up. Are you sure somthing didn't happen when you disconnected it? I don't know whats up all I want is what I paid for. I just shelled out a grand in other parts but I can't install them until I get a working PC III.[/QUOTE]

no nothing happened when i disconnected it... it was running when i drove it into the garage and took it off... as far as being hacked up i never even saw anything hacked up on it other than the plug cut off.. it worked great for me and should be for you so i cannot understand why it would not be working unless someone screwed it up on your end...[/QUOTE]

Not on this end, I got it in the mail and my intitial thought was wow this thing looks jacked up...took a closer look and found several other cuts in the insulation and two other wires with butt connectors going to them and electrical tape over them. Thats a big foul when it comes to computer controls...the computer uses resistance values to control the fuel and butt connectors won't cut it. I was cool with soldering three wires together (like stated in the listing) but this harness is all jacked up. No way would I install this...didn't even get that far...called up dynojet they said they would fix the wiring for free...then they sent me the email you got in the first reponse...are you saying dynojet is not qualified to test this unit? Because I did nothing more than look at it then send it off to dynojet. I just want to resolve this and get another one on the way.[/QUOTE]
first off it was not all beat up... the box was in very good shape....explain how it was "jacked up"....[/QUOTE]

Rub mark in the bottom (from not being secured), external port plugs missing, cuts in the wiring, butt connectors, one of the adjustment buttons sticky operation. I wasn't two worried about any of this stuff because it is used but the wiring was way worse than described weather you noticed or not you are still responsable. Don't know whats up with it not working but I trust the manufacturer to make that determination. I can understand your frustration, but it was not as described bottom line. As far as it working when you took it off...are you sure it was working correctly?...Is it possable it was damaged in shipping?...It was just tossed in a padded envelope? I really don't enjoy arguing over this...I shouldn't have to...bottom line I want to return it because the wiring was not as decribed.[/QUOTE]

sorry no returns... worked great when taken off told you about the plug being cut off... a bubble mailer is more than sufficient to ship it in... who cares about a rub mark anyways its USED...not "perfect" adjustment button being sticky,its on an "all terrain vehicle" probillay has a little dirt in it, not at all uncommon...and besides nobody uses those anyways its all done on the computer with maps and the uploaded on the pc3...[/QUOTE]

Like I said I wasn't all that worried about the other stuff, just bringing it up because you asked.[/QUOTE]
 

·
Registered
Joined
·
24 Posts
Discussion Starter #4
anyway its too nice out to be arguing about this..time to put the stock parts back on and go ride...I realize at this point I am out my money...lesson learned...will send you picks anyway as soon as I get it back...don't bother to respond...done with it
 

·
Registered
Joined
·
823 Posts
anyway its too nice out to be arguing about this..time to put the stock parts back on and go ride...I realize at this point I am out my money...lesson learned...will send you picks anyway as soon as I get it back...don't bother to respond...done with it
If he is truly at fault then you should be entitled to your money back. I wouldn't just give up. Pretty shady for someone to sell shit and then say no returns when it doesnt work. Sorry you got taken by that type of guy.
 

·
Registered
Joined
·
24 Posts
Discussion Starter #6
At least someone agrees with me:thumb: Could have been a fluke that it stopped working between hear and there but its sounding a little shady...gotta send pics to the guy when I get back in town this weekend (if its back from dynatek). Still may try to get my money back through pay pal.
 

·
Registered
Joined
·
823 Posts
I would definitely try, I would be pissed to be taken for that kind of money and have nothing to show for it except for a dirty broken POS.
 

·
Registered
Joined
·
58 Posts
If you show PayPal these post I bet you will get your maoney back especially since the maker cant even fix it...
 

·
Registered
Joined
·
872 Posts
I would definetely try to get your money back. Sounds pretty shady to me too. Sucks that there are people selling things and not holding up there end of the deal. Very cowardly to not take responsability for the item that you ship to another member. Hope it works out for ya.
 

·
Registered
Joined
·
441 Posts
This is all prety shady on that guys side. You've seemed more then nice to the guy. I think he should do the right thing and get you your money back.
 

·
Registered
Joined
·
823 Posts
So let's have an update if we could, I really hope that JustinBCrazy stepped up to the plate because right now it it seems more like JustinBAnAsshole...
 

·
Registered
Joined
·
86 Posts
From your description, sounds like it fried from all the cut wires n all. Its very easy to short out an electronic device, my guess is that is was "broken" before it was shipped.

It being unsecured in his quad actually is a big deal. The unit moves around and bangs against where it was installed. Not only do you have the constant shock to the unit but it also stresses the wires by moving around. Now add that in with possible water touching those exposed wires and creating a short....which has a great possibility of frying the internals.

Was there any type of "sold as is" statement? If not, it doesn't sound like a hard small claims case to win. Yes it takes time to file and appear in court but you can also ask for all fees/costs to be paid for by seller...plus it teaches someone to be honorable next time around. You are way within your right asking for a refund, the seller in this case is on the bad side in numerous ways.

I never buy any type of "used" electronic, the risk is too great in it not working or being on its last leg. Good luck in this ordeal.
 

·
Registered
Joined
·
302 Posts
This is why I ask for complete pictures of everything I buy online, and most of the time I get phone numbers and talk to them personally before I make the deal. If this is the case, I say that if he doesn't make it right, he should be banned from the site. People like that make a bad name for everyone.

On the other side of the coin, it could have got fried when you first hooked it up. Maybe the battery wasn't disconnected first, and it got a surge and fried. Nobody will ever know, except for you two guys.
 
1 - 15 of 15 Posts
Top